How To Export A Fractal From
Mandelbulb 3D

Programs you need : Mandelbulb 3d v1.99 or latest version for best results
https://fractalforums.org/index.php?action=downloads;sa=view;down=2
Meshlab 2016 http://www.meshlab.net/

Fiji (Method 2) https://imagej.net/Fiji/Downloads

Blender 3D https://www.blender.org/ (or the 3d software of your choice)

I should start by mentioning that before you export your fractal, there are 3 main methods | will
go over to get your object ready for use in another 3d program, like Blender. | will give a quick
overview of the 3 main methods | have used.

Method 1: Use the Bulbtracer option to turn the fractal directly into an .OBJ file

Method 2: Use the Voxelstack option and compile the image stack in Fiji, then export as an
.OBJ file

Method 3: Use the Bulbtracer option to turn the fractal into a point cloud. It can then be turned
into a mesh using Meshlab 2016

All of these methods have their own pros and cons so it is up to you to find the method that
works for you and your fractals. This is just intended to be a template you can start with.

Method 1: Bulbtracer to .OBJ

Method 2: Voxel Stacks

Method 3: Point Clouds

Method 1: Bulbtracer to .OBJ



https://fractalforums.org/index.php?action=downloads;sa=view;down=2
http://www.meshlab.net/
https://imagej.net/Fiji/Downloads
https://www.blender.org/

Step 1: Create your fractal. Click on the BTracer button.
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Step 2: Mesh Properties
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1) Import your parameters from the main window. If necessary, decrease overall scale until you
see your whole fractal in the preview window. Set preview size to 2562 for the highest resolution
preview.

2) Mesh properties settings:

Mesh type: Mesh

Volumetric Resolution could be anywhere from about 400x400x400 to 1000x1000x1000, but the
higher the number, the more faces and vertices it will produce. Find a size that works best for
your fractal.

uncheck taubin smooth, save type: Mesh as OBJ

3) Click “Generate Mesh”. This may take a while. When its finished, it will save to your
Mandelbulb 3d Meshes folder by default.

Step 3: Meshlab
Open your .OBJ file in Meshlab and follow the cleaning steps....

e Filters -> Cleaning and Repairing -> Merge Close Vertices. Apply
e Filters -> Cleaning and Repairing -> Remove duplicate faces. Apply
e Filters -> Cleaning and Repairing -> Remove duplicated vertex. Apply



Filters -> Cleaning and Repairing -> Remove zero area faces. Apply

Filters -> Cleaning and Repairing -> Remove unreferenced vertices. Apply

Filters -> Cleaning and Repairing -> Remove faces from non manifold edges. Apply
Filters -> Remeshing, Simplification and Reconstruction -> Close Holes. Apply

Filters -> Normals, Curvature and Orientation -> Re-Orient All faces Coherently

Some of these cleaning steps may seem redundant or unnecessary for your fractal. Experiment
until you find what works best.

*Optional - Your mesh may have turned out to have millions of faces and vertices. To reduce
the total number of polygons to make it a little easier to work with, you can then go to...

e Filters -> Remeshing, Simplification and Reconstruction -> Simplification: Quadric Edge
Collapse Decimation. Enter your desired target number of faces. Check the boxes
Preserve Normal, Optimal Position of Simplified Vertices, Planar Simplification,
Post-simplification cleaning, and Uncheck all of the rest. Apply

When doing this, you will lose some of the detail of your fractal because you are changing the
overall geometry.

Simplify 8 mesh using 3 Quadhic hased Fdge Collaose
Strategy; better than dustering but slower

Target number of faces 29000
Percentage reduction (0.. 1) l:l
Quality threshold 0.3

[ Preserve Boundary of the mesh

4 Boundary Preserving Weight
|

Preserve Normal

| [ Preserve Topology

| Optimal position of simplified vertices
1 Planar Simplification
[ weighted Simplification
Post-simplification deaning
[ simplify only selected faces

Default

Close

e Filters -> Cleaning and Repairing -> Remove faces from non manifold edges. Apply
If your mesh looks a bit jagged or rough, you can smooth it out, but you may lose some of the
fine details. Go to...

e Filters -> Smoothing, Fairing, and Deformation -> HP Laplacian Smooth. Apply

When you are satisfied with your mesh, go to File ->Export

Method 2: Voxel Stacks




Step 1: Create your fractal. Click the Tools Tab, then the Voxelstack button.
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Step 2: Mesh Properties

1) Import your parameters from the main window. If necessary, decrease overall scale until you
see your whole fractal in the preview window. Set preview size to 2562 for the highest resolution
preview.
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2) Mesh properties settings:

Z slices (Volumetric Resolution) could be anywhere from about 400x400x400 to
1000x1000x1000, but the higher the number, the more faces and vertices it will produce. Find a
size that fits for your fractal.

3) Click “Start rendering slices”. This may take a while. They will save to your Mandelbulb 3d
folder by default.
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Step 3: Fiji ImageJ
e Import your voxel stacks in Fiji: File -> Import -> Image Sequence. Choose the first
image in the sequence that was rendered and click open.
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Check Use Virtual Stack and click ok.
Go to File -> Save As -> PGM. You can save it in a folder of your choice.
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e Go to File -> Save As -> Wavefront .OBJ. Set Threshold to 0, UNcheck Green and
UNcheck Blue and click ok.
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Once you save the file, Fiji will start compiling the images. You will see a progress bar fill up but
check the size of your file. When the file size stops increasing, you will know it has finished
writing the file.

Step 4: Meshlab
Open your .OBJ file in Meshlab and follow the cleaning steps....

Filters -> Normals, Curvature and Orientation -> Invert Face Orientation. Apply
Filters -> Cleaning and Repairing -> Merge Close Vertices. Apply

Filters -> Remeshing, Simplification and Reconstruction -> Close Holes. Apply

Filters -> Normals, Curvature and Orientation -> Re-Orient All faces Coherently



*Optional - Your mesh may have turned out to have millions of faces and vertices. To reduce
the total number of polygons to make it a little easier to work with, you can then go to...

e Filters -> Remeshing, Simplification and Reconstruction -> Simplification: Quadric Edge
Collapse Decimation. Enter your desired target number of faces. Check the boxes
Preserve Normal, Optimal Position of Simplified Vertices, Planar Simplification,
Post-simplification cleaning, and Uncheck all of the rest. Apply.

When doing this, you will lose some of the detail of your fractal because you are changing the
overall geometry.

Simplify 8 mesh using 3 Quadhic hased Fdge Collaose
Strategy; better than dustering but slower

Target number of faces 29000
Percentage reduction (0.. 1) l:l
Quality threshold 0.3

[ Preserve Boundary of the mesh

Y Boundary Preserving Weight
Preserve Normal

[[] Preserve Topology

| Optimal position of simplified vertices

I J Planar Simplification

B [ weighted Simplification
Post-simplification cleaning
[ simplify only selected faces

Default

Close

e Filters -> Cleaning and Repairing -> Remove faces from non manifold edges. Apply
If your mesh looks a bit jagged or rough, you can smooth it out, but you may lose some of the
fine details. Go to...

e Filters -> Smoothing, Fairing, and Deformation -> HP Laplacian Smooth. Apply

When you are satisfied with your mesh, go to File ->Export

Method 3: Point Clouds

Step 1: Create your fractal in Mandelbulb 3d 1.99 or the most current version. Click on the
BTracer button.
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Step 2: Mesh Properties

1) Import your parameters from the main window. If necessary, decrease overall scale until you
see your whole fractal in the preview window. Set preview size to 2562 for the highest resolution
preview.
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2) Mesh properties settings:

Mesh type: Point Cloud

Volumetric Resolution could be anywhere from about 1000x1000x1000 to 2000x2000x2000, but
the higher the number, the more faces and vertices it will produce. Find a size that works best
for your fractal.

Check approximate normals, save type: Mesh as PLY

3) Click “Generate Mesh”. This may take a while. When its finished, it will save to your
Mandelbulb 3d Meshes folder by default.

Step 3: Meshlab
Go to Meshlab and follow the steps for your PLY (Point Cloud) file

Filters -> Normals, Curvature, and Orientation -> Compute normals for point sets. Apply
Filters -> Remeshing, Simplification, and Reconstruction -> Screened Poisson Surface
Reconstruction. Apply (Reconstruction depth controls the level of detail in the
reconstruction. It can be raised slightly, but it will take longer to process.)
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Sometimes this process can create extra geometry, and your mesh may look blown up like a
balloon. It seems you can avoid this by making sure your normals are correct before you
reconstruct your mesh. To try to delete the extra geometry, you can go to:
e Filters > Selection > Select faces with edges larger than... (Check preview and select
threshold amount; {ex. 0005}). Delete Selection
Or...
e Filters > Selection > Select by Vertex quality (Check preview and select a min/max
quality; Apply. Delete Selection
If your mesh looks unusually dark, you may have to flip normals
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e Filters -> Normals, Curvature and Orientation -> Invert Face Orientation. Apply. (Make
sure you have the poisson mesh selected.)

e Filters -> Sampling -> Vertex Attribute Color (check transfer color, normals). Apply
(Source: M3D PLY, Target: Poisson Mesh). Apply. After you transfer normals to the new
mesh, you may have to flip them again. If so, go to...

e Filters -> Normals, Curvature and Orientation -> Invert Face Orientation. Apply. (Make
sure you have the poisson mesh selected.)
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If your mesh looks a bit jagged or rough, you can smooth it out, but you may lose some of the
fine details. Go to...



e Filters -> Smoothing, Fairing, and Deformation -> HP Laplacian Smooth. Apply
When you are satisfied with your mesh, go to File ->Export Mesh As. Name the file, click save
and ok. Saving as a ply file will preserve the color data.

Note: Sometimes point clouds with over approx. 1,000,000 vertices will not compute all normals
correctly.

If you are having trouble with your normals, start over with this method:
e Filters -> Normals, Curvature, and Orientation -> Per Vertex Normal Function. Keep

default settings and Apply. It will compute normals on every vertex so they are all facing
inward.
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e Filters -> Remeshing, Simplification, and Reconstruction -> Screened Poisson Surface
Reconstruction. Apply (Reconstruction depth controls the level of detail in the
reconstruction. It can be raised slightly, but it will take longer to process.)

If your mesh still looks unusually dark, you will have to flip normals
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e Filters -> Normals, Curvature and Orientation -> Invert Face Orientation. Apply. (Make
sure you have the poisson mesh selected.)
e Filters -> Sampling -> Vertex Attribute Color (check transfer color). Apply (Source: M3D
PLY, Target: Poisson Mesh).
When you are satisfied with your mesh, go to File ->Export. Name the file, click save and ok.
Saving as a ply file will preserve the color data.

NOTE: When exporting as a point cloud the color data can, but won'’t always, transfer
completely to your satisfaction on some fractals. You can always re-color your mesh in the 3d
program of your choice. Here, | am using Blender for example:
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Now you can let your imagination take over!

A Trio of Discostars



And there you have it. A special thanks to Don Whitaker, Nic022 (RIP), Mandelwerk, Michael A.
Prostka, Harry Rose, Andreas Maschke, and the rest of Mandelbulb 3D community for the
support and inspiration!
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